Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Softaculous does not detect correct PHP version.
#1
Issue:

While installing application via Softaculous Application Installer it appears the following error message :
 
==========
"Required PHP version greater than equal to 5.4.45 AND found version is : 5.3.3".
==========

Note : In this case the server has PHP 5.3.3 version and the script required higher version. 

Solution :

Login to your server > rename the "pre_install.txt" file located in /usr/local/softaculous/enduser/hooks/ path to "pre_install.php", add below code to identify the PHP version and try to re-install the application.

============================================
function __pre_install(){
        global $soft, $software, $globals;
        // Do stuff here e.g. is as follows
$version = '5.4.45';
        define('php_version', $version);
============================================

Let us know your thoughts on this.
  


Forum Jump:


Users browsing this thread:
1 Guest(s)